What’s Vulnerable › Vulnerabilities

CVE-2025-14869: Improper Validation of Specified Quantity in Input in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.5 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3 that could have allowed an unauthenticated user to cause denial of service by sending specially crafted payloads on certain API endpoints.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.6, 18.11.3, 18.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-14869 or the next vulnerability affects your stack