What’s Vulnerable › Vulnerabilities
CVE-2025-14881: Insecure direct object reference
- Severity: low (CVSS 3.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-19 · updated 2026-10-14
- Weakness: CWE-639
Description
Multiple API endpoints allowed access to sensitive files from other users by knowing the UUID of the file that were not intended to be accessible by UUID only.
Affected products
- pretix: from 1.0.0 before 2025.8.0; from 2025.8.0 before 2025.9.0; from 2025.9.0 before 2025.10.0; from 2025.10.0 before 2025.11.0 — fixed in 2025.10.0, 2025.11.0, 2025.8.0, 2025.9.0
How to fix
Upgrade to a fixed version: pretix 2025.10.0, 2025.11.0, 2025.8.0, 2025.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-14881 or the next vulnerability affects your stack