What’s Vulnerable › Vulnerabilities
CVE-2025-14923: IBM WebSphere Application Server Liberty could provide weaker than expected security
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-03 · updated 2026-06-17
- Weakness: CWE-321
Description
IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.2 IBM WebSphere Application Server Liberty could provide weaker than expected security when using the Security Utility when administering security settings.
Affected products
- IBM WebSphere Application Server: from 17.0.0.3 before 26.0.0.3 — fixed in 26.0.0.3
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 26.0.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-14923 or the next vulnerability affects your stack