What’s Vulnerable › Vulnerabilities
CVE-2025-14946: Libnbd: libnbd: arbitrary code execution via ssh argument injection through a malicious uri
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-19 · updated 2026-10-07
- Weakness: CWE-88
Description
A flaw was found in libnbd. A malicious actor could exploit this by convincing libnbd to open a specially crafted Uniform Resource Identifier (URI). This vulnerability arises because non-standard hostnames starting with '-o' are incorrectly interpreted as arguments to the Secure Shell (SSH) process, rather than as hostnames. This could lead to arbitrary code execution with the privileges of the user running libnbd.
Affected products
- [UNKNOWN] libnbd: from 1.22.0 before 1.22.5; from 1.23.0 before 1.23.9 — fixed in 1.22.5, 1.23.9
- Red Hat Enterprise Linux 10: all versions
How to fix
Upgrade to a fixed version: [UNKNOWN] libnbd 1.22.5, 1.23.9. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-14946
- https://bugzilla.redhat.com/show_bug.cgi?id=2423789
- https://libguestfs.org/libnbd-release-notes-1.24.1.html#Security
Get alerted when CVE-2025-14946 or the next vulnerability affects your stack