What’s Vulnerable › Vulnerabilities
CVE-2025-1497: Remote Code Execution in PlotAI
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-10 · updated 2026-06-17
- Weakness: CWE-94
Description
A vulnerability, that could result in Remote Code Execution (RCE), has been found in PlotAI. Lack of validation of LLM-generated output allows attacker to execute arbitrary Python code. Vendor commented out vulnerable line, further usage of the software requires uncommenting it and thus accepting the risk. The vendor does not plan to release a patch to fix this vulnerability.
Affected products
- MLJAR PlotAI: before 0.0.7 — fixed in 0.0.7
How to fix
Upgrade to a fixed version: MLJAR PlotAI 0.0.7. Check the vendor advisory for mitigations.
References
- https://cert.pl/en/posts/2025/03/CVE-2025-1497
- https://cert.pl/posts/2025/03/CVE-2025-1497
- https://github.com/mljar/plotai
- https://github.com/mljar/plotai/commit/bdcfb13484f0b85703a4c1ddfd71cb21840e7fde
Get alerted when CVE-2025-1497 or the next vulnerability affects your stack