What’s Vulnerable › Vulnerabilities
CVE-2025-15033: WooCommerce - Subscriber/Customer+ Order Data Disclosure
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-22 · updated 2026-10-19
- Weakness: CWE-200
Description
A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.
Affected products
- Automattic WooCommerce: from 8.1.0 before 8.1.3; from 8.2.0 before 8.2.4; from 8.3.0 before 8.3.3; from 8.4.0 before 8.4.2; from 8.5.0 before 8.5.4; from 8.6.0 before 8.6.3 — fixed in 10.0.5, 10.1.3, 10.2.3, 10.3.7, 10.4.3, 8.1.3
How to fix
Upgrade to a fixed version: Automattic WooCommerce 10.0.5, 10.1.3, 10.2.3, 10.3.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15033 or the next vulnerability affects your stack