What’s Vulnerable › Vulnerabilities
CVE-2025-1505: Advanced AJAX Product Filters <= 1.6.8.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced AJAX Product Filters plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'nonce' parameter in all versions up to, and including, 1.6.8.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- BeRocket Advanced AJAX Product Filters: before 1.6.8.2 — fixed in 1.6.8.2
How to fix
Upgrade to a fixed version: BeRocket Advanced AJAX Product Filters 1.6.8.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3245830/woocommerce-ajax-filters/trunk/includes/wizard.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/94b289bf-0ef1-47d1-98bd-8f7bb753c2bc?source=cve
Get alerted when CVE-2025-1505 or the next vulnerability affects your stack