What’s Vulnerable › Vulnerabilities
CVE-2025-15079: libssh global known_hosts override
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-08 · updated 2026-10-14
- Weakness: CWE-297
Description
When doing SSH-based transfers using either SCP or SFTP, and setting the known_hosts file, libcurl could still mistakenly accept connecting to hosts *not present* in the specified file if they were added as recognized in the libssh *global* known_hosts file.
Affected products
- curl: from 7.58.0 before 8.18.0 — fixed in 8.18.0
How to fix
Upgrade to a fixed version: curl 8.18.0. Check the vendor advisory for mitigations.
References
- https://curl.se/docs/CVE-2025-15079.html
- https://curl.se/docs/CVE-2025-15079.json
- https://hackerone.com/reports/3477116
- http://www.openwall.com/lists/oss-security/2026/01/07/6
Get alerted when CVE-2025-15079 or the next vulnerability affects your stack