What’s Vulnerable › Vulnerabilities

CVE-2025-1516: Allocation of Resources Without Limits or Throttling in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 8.7 before 17.10.8, 17.11 before 17.11.4, and 18.0 before 18.0.2. Improper input validation in Tokens Names could be used to trigger a denial of service.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.10.8, 17.11.4, 18.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-1516 or the next vulnerability affects your stack