What’s Vulnerable › Vulnerabilities
CVE-2025-15224: libssh key passphrase bypass without agent set
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-08 · updated 2026-10-14
- Weakness: CWE-287
Description
When doing SSH-based transfers using either SCP or SFTP, and asked to do public key authentication, curl would wrongly still ask and authenticate using a locally running SSH agent.
Affected products
- curl: from 7.58.0 before 8.18.0 — fixed in 8.18.0
How to fix
Upgrade to a fixed version: curl 8.18.0. Check the vendor advisory for mitigations.
References
- https://curl.se/docs/CVE-2025-15224.html
- https://curl.se/docs/CVE-2025-15224.json
- https://hackerone.com/reports/3480925
- http://www.openwall.com/lists/oss-security/2026/01/07/7
Get alerted when CVE-2025-15224 or the next vulnerability affects your stack