What’s Vulnerable › Vulnerabilities
CVE-2025-1530: Tripetto <= 8.0.9 - Cross-Site Request Forgery to Arbitrary Results Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-15 · updated 2026-06-17
- Weakness: CWE-352
Description
The Tripetto plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 8.0.9. This is due to missing nonce validation. This makes it possible for unauthenticated attackers to delete arbitrary results via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- tripetto WordPress form builder plugin for contact forms, surveys and quizzes – Tripetto: before 8.0.10 — fixed in 8.0.10
How to fix
Upgrade to a fixed version: tripetto WordPress form builder plugin for contact forms, surveys and quizzes – Tripetto 8.0.10. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/tripetto/trunk/lib/capabilities.php
- https://plugins.trac.wordpress.org/changeset/3251202/
- https://plugins.trac.wordpress.org/changeset/3251202/tripetto/trunk/admin/results/list.php
- https://plugins.trac.wordpress.org/changeset/3251202/tripetto/trunk/admin/results/results.php
- https://wordpress.org/plugins/tripetto/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dd80abd9-3f41-414a-a781-9bff7d85ec4b?source=cve
Get alerted when CVE-2025-1530 or the next vulnerability affects your stack