What’s Vulnerable › Vulnerabilities

CVE-2025-1534: Cross-site Scripting (Stored)

Description

CVE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Payara Platform Payara Server allows : Remote Code Inclusion.This issue affects Payara Server: from 4.1.2.1919.1 before 4.1.2.191.51, from 5.20.0 before 5.68.0, from 6.0.0 before 6.23.0, from 6.2022.1 before 6.2025.2.

Affected products

How to fix

Upgrade to a fixed version: Payara Platform Payara Server 4.1.2.191.51, 5.68.0, 6.2025.3, 6.24.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-1534 or the next vulnerability affects your stack