What’s Vulnerable › Vulnerabilities
CVE-2025-15382: Client SCP Request Triggers Buffer Overread by 1 Byte
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-06 · updated 2026-10-13
- Weakness: CWE-125
Description
A heap buffer over-read vulnerability exists in the wolfSSH_CleanPath() function in wolfSSH. An authenticated remote attacker can trigger the issue via crafted SCP path input containing '/./' sequences, resulting in a heap over read by 1 byte.
Affected products
- wolfSSL Inc. wolfSSH: from 1.4.12 before 1.4.22 — fixed in 1.4.22
How to fix
Upgrade to a fixed version: wolfSSL Inc. wolfSSH 1.4.22. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15382 or the next vulnerability affects your stack