What’s Vulnerable › Vulnerabilities
CVE-2025-15396: Library Viewer < 3.2.0 - Reflected Cross-Site Scripting
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Library Viewer WordPress plugin before 3.2.0 does not sanitise and escape some parameters before outputting them back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- Library Viewer: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: Library Viewer 3.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15396 or the next vulnerability affects your stack