What’s Vulnerable › Vulnerabilities

CVE-2025-1540: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab CE/EE for Self-Managed and Dedicated instances affecting all versions from 17.5 prior to 17.6.5, 17.7 prior to 17.7.4, and 17.8 prior to 17.8.2. It was possible for a user added as an External to read and clone internal projects under certain circumstances."

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.6.5, 17.7.4, 17.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-1540 or the next vulnerability affects your stack