What’s Vulnerable › Vulnerabilities
CVE-2025-15444: Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-06 · updated 2026-10-07
- Weakness: CWE-347
Description
Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium libsodium <= 1.0.20 or a version of libsodium released before December 30, 2025 contains a vulnerability documented as CVE-2025-69277 https://www.cve.org/CVERecord?id=CVE-2025-69277 . The libsodium vulnerability states: In atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group. 0.000042 includes a version of libsodium updated to 1.0.20-stable, released January 3, 2026, which includes a fix for the vulnerability.
Affected products
- IAMB Crypt::Sodium::Xs: before 0.000042 — fixed in 0.000042
How to fix
Upgrade to a fixed version: IAMB Crypt::Sodium::Xs 0.000042. Check the vendor advisory for mitigations.
References
- https://00f.net/2025/12/30/libsodium-vulnerability/
- https://github.com/jedisct1/libsodium/commit/ad3004ec8731730e93fcfbbc824e67eadc1c1bae
- https://metacpan.org/dist/Crypt-Sodium-XS/changes
Get alerted when CVE-2025-15444 or the next vulnerability affects your stack