What’s Vulnerable › Vulnerabilities
CVE-2025-1547: WatchGuard Firebox Authenticated Stack Overflow in Certificate Request Command
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-04 · updated 2026-09-25
- Weakness: CWE-121
Description
A stack-based buffer overflow vulnerability [CWE-121] in WatchGuard Fireware OS's certificate request command could allow an authenticated privileged user to execute arbitrary code via specially crafted CLI commands.
Affected products
- WatchGuard Fireware OS: from 12.0.0 before 12.11.3; from 12.5 before 12.5.13 — fixed in 12.11.3, 12.5.13
How to fix
Upgrade to a fixed version: WatchGuard Fireware OS 12.11.3, 12.5.13. Check the vendor advisory for mitigations.
References
- https://psirt.watchguard.com/CVE-2025-1547
- https://www.watchguard.com/wgrd-psirt/advisory/wgsa-2025-00013
Get alerted when CVE-2025-1547 or the next vulnerability affects your stack