What’s Vulnerable › Vulnerabilities
CVE-2025-15520: RegistrationMagic <= 6.0.7.2 - Subscriber+ Sensitive Data Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-13 · updated 2026-06-17
Description
The RegistrationMagic WordPress plugin before 6.0.7.2 checks nonces but not capabilities, allowing for the disclosure of some sensitive data to subscribers and above.
Affected products
- Metagauss RegistrationMagic: before 6.0.7.2 — fixed in 6.0.7.2
How to fix
Upgrade to a fixed version: Metagauss RegistrationMagic 6.0.7.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15520 or the next vulnerability affects your stack