What’s Vulnerable › Vulnerabilities
CVE-2025-15557: Improper Certificate Validation in TP-Link Tapo H100 and P100 Allows Man-in-the-Middle Attack
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-05 · updated 2026-06-17
- Weakness: CWE-295
Description
An Improper Certificate Validation vulnerability in TP-Link Tapo H100 v1 and Tapo P100 v1 allows an on-path attacker on the same network segment to intercept and modify encrypted device-cloud communications. This may compromise the confidentiality and integrity of device-to-cloud communication, enabling manipulation of device data or operations.
Affected products
- TP-Link Tapo H100 IoT Smart Hub: before 1.6.1 — fixed in 1.6.1
- TP-Link Tapo P100 Firmware: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: TP-Link Tapo H100 IoT Smart Hub 1.6.1; TP-Link Tapo P100 Firmware 1.2.6. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/tapo-h100/
- https://www.tp-link.com/en/support/download/tapo-p100/
- https://www.tp-link.com/us/support/download/tapo-h100/
- https://www.tp-link.com/us/support/download/tapo-p100/
- https://www.tp-link.com/us/support/faq/4949/
Get alerted when CVE-2025-15557 or the next vulnerability affects your stack