What’s Vulnerable › Vulnerabilities
CVE-2025-15566: ingress-nginx auth-proxy-set-headers nginx configuration injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-06 · updated 2026-06-17
- Weakness: CWE-20
Description
A security issue was discovered in ingress-nginx where the `nginx.ingress.kubernetes.io/auth-proxy-set-headers` Ingress annotation can be used to inject configuration into nginx. This can lead to arbitrary code execution in the context of the ingress-nginx controller, and disclosure of Secrets accessible to the controller. (Note that in the default installation, the controller can access all Secrets cluster-wide.)
Affected products
- Kubernetes ingress-nginx: before 1.12.5; before 1.13.1 — fixed in 1.12.5, 1.13.1
How to fix
Upgrade to a fixed version: Kubernetes ingress-nginx 1.12.5, 1.13.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15566 or the next vulnerability affects your stack