What’s Vulnerable › Vulnerabilities
CVE-2025-1561: AppPresser – Mobile App Framework <= 4.4.10 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The AppPresser – Mobile App Framework plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'title' parameter in all versions up to, and including, 4.4.10 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages when logging is enabled that will execute whenever a user accesses an injected page.
Affected products
- scottopolis AppPresser – Mobile App Framework: before 4.4.11 — fixed in 4.4.11
How to fix
Upgrade to a fixed version: scottopolis AppPresser – Mobile App Framework 4.4.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/apppresser/tags/4.4.10/templates/template.php#L32
- https://plugins.trac.wordpress.org/changeset/3254632/apppresser/tags/4.4.11/inc/AppPresser_Log_Admin.php?old=3219464&old_path=apppresser%2Ftags%2F4.4.10%2Finc%2FAppPresser_Log_Admin.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/77328e35-b6e6-40eb-8c85-896d54419aef?source=cve
Get alerted when CVE-2025-1561 or the next vulnerability affects your stack