What’s Vulnerable › Vulnerabilities
CVE-2025-15612: Wazuh Provisioning Scripts / Build Infrastructure Improper Certificate Validation leading to MITM and RCE
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-27 · updated 2026-10-07
- Weakness: CWE-295
Description
Wazuh provisioning scripts and Dockerfiles contain an insecure transport vulnerability where curl is invoked with the -k/--insecure flag, disabling SSL/TLS certificate validation. Attackers with network access can perform man-in-the-middle attacks to intercept and modify downloaded dependencies or code during the build process, leading to remote code execution and supply chain compromise.
Affected products
- wazuh: from 4.1.3 before 4.14.0 — fixed in 4.14.0
How to fix
Upgrade to a fixed version: wazuh 4.14.0. Check the vendor advisory for mitigations.
References
- https://github.com/wazuh/wazuh/security/advisories/GHSA-wvg9-7q49-c7mg
- https://www.vulncheck.com/advisories/various-uses-of-curl-without-verifying-the-authenticity-of-the-ssl-certificate-leading-to-mitm-rce-in-build-infrastructure
Get alerted when CVE-2025-15612 or the next vulnerability affects your stack