What’s Vulnerable › Vulnerabilities
CVE-2025-15614: ugrep before 7.6.0 Heap Buffer Over-read via .Z decompression
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-10-19
- Weakness: CWE-125
Description
ugrep before 7.6.0 contains a heap buffer over-read vulnerability in the LZW decompressor when processing crafted .Z archive files. Attackers can supply malformed .Z files that cause the decompressor to read one byte past the allocated heap buffer, potentially crashing the process.
Affected products
- Genivia ugrep: before 7.6.0 — fixed in 7.6.0
How to fix
Upgrade to a fixed version: Genivia ugrep 7.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/Genivia/ugrep
- https://github.com/Genivia/ugrep/blob/v7.5.0/src/zopen.c#L673
- https://github.com/Genivia/ugrep/commit/c12849a11264e2c81c860bf78ee9039772f307a4
- https://github.com/Genivia/ugrep/issues/511
- https://github.com/Genivia/ugrep/releases/tag/v7.6.0
- https://www.vulncheck.com/advisories/ugrep-before-7.6.0-heap-buffer-over-read-via-z-decompression
Get alerted when CVE-2025-15614 or the next vulnerability affects your stack