What’s Vulnerable › Vulnerabilities

CVE-2025-15638: Net::Dropbear versions before 0.14 for Perl contains a vulnerable version of libtomcrypt

Description

Net::Dropbear versions before 0.14 for Perl contains a vulnerable version of libtomcrypt. Net::Dropbear versions before 0.14 includes versions of Dropbear 2019.78 or earlier. These include versions of libtomcrypt v1.18.1 or earlier, which is affected by CVE-2016-6129 and CVE-2018-12437.

Affected products

How to fix

Upgrade to a fixed version: ATRODO Net::Dropbear 0.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-15638 or the next vulnerability affects your stack