What’s Vulnerable › Vulnerabilities
CVE-2025-15645: Ledger Nano X, Flex, Stax MCU Firmware Update Denial of Service
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-07-24
- Weakness: CWE-1284
Description
Ledger Nano X, Flex, and Stax devices contain a denial of service vulnerability in the MCU firmware update process due to missing validation of the reset_handler parameter during firmware flashing. An attacker can provide a crafted reset_handler address pointing to invalid memory or attacker-controlled code to cause the device to enter an unrecoverable fault state during boot, resulting in permanent loss of operability.
Affected products
- Ledger Flex: before 1.2.2 — fixed in 1.2.2
- Ledger Nano X: before 2.4.2 — fixed in 2.4.2
- Ledger Stax: before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: Ledger Flex 1.2.2; Ledger Nano X 2.4.2; Ledger Stax 1.6.2. Check the vendor advisory for mitigations.
References
- https://donjon.ledger.com/lsb/021/
- https://www.vulncheck.com/advisories/ledger-nano-x-flex-stax-mcu-firmware-update-denial-of-service
Get alerted when CVE-2025-15645 or the next vulnerability affects your stack