What’s Vulnerable › Vulnerabilities
CVE-2025-15662: Printcart Web to Print Product Designer for WooCommerce < 2.5.3 - Unauthenticated Arbitrary File Read and Server-Side Request Forgery
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-27 · updated 2026-09-29
- Weakness: CWE-918
Description
The Printcart Web to Print Product Designer for WooCommerce WordPress plugin before 2.5.3 does not restrict a user-supplied URL before fetching it server-side and does not enforce a valid authorization check, allowing unauthenticated attackers to read arbitrary local files (including configuration files containing database credentials and secret keys) and to make server-side requests to internal resources.
Affected products
- Printcart Web to Print Product Designer for WooCommerce: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: Printcart Web to Print Product Designer for WooCommerce 2.5.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15662 or the next vulnerability affects your stack