What’s Vulnerable › Vulnerabilities
CVE-2025-15665: BEAF < 4.7.1 - Admin+ Stored XSS via Widget Shortcode Field
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-09-29
Description
The Ultimate Before After Image Slider & Gallery WordPress plugin before 4.7.1 does not escape the value of the BEAF Slider widget's shortcode field before outputting it on the front end (the value is passed through do_shortcode, which echoes non-shortcode content verbatim), allowing users with administrator-level access to store a script that executes in the browser of any visitor who loads a page displaying the widget.
Affected products
- Ultimate Before After Image Slider & Gallery: before 4.7.1 — fixed in 4.7.1
How to fix
Upgrade to a fixed version: Ultimate Before After Image Slider & Gallery 4.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15665 or the next vulnerability affects your stack