What’s Vulnerable › Vulnerabilities
CVE-2025-15669: Bit Form < 3.1.4 - Admin+ Stored XSS via Conversational Form Progress Label
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-01 · updated 2026-09-29
- Weakness: CWE-79
Description
The Bit Form WordPress plugin before 3.1.4 does not sanitise one of its conversational-form display settings before rendering it on the public-facing form, allowing high-privilege users (such as administrators, who do not hold the unfiltered_html capability on multisite) to store JavaScript that executes in the browser of any visitor who views the form.
Affected products
- Bit Form: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: Bit Form 3.1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15669 or the next vulnerability affects your stack