What’s Vulnerable › Vulnerabilities
CVE-2025-15671: Welcart e-Commerce < 2.12.1 - Session Fixation via uscesid Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-21 · updated 2026-09-29
- Weakness: CWE-287
Description
The Welcart e-Commerce WordPress plugin before 2.12.1 does not regenerate the session identifier on authentication and sets the session identifier from a user-supplied request parameter, allowing an unauthenticated attacker to fixate a shop member's session and take over their customer account after the victim logs in through an attacker-crafted request.
Affected products
- Welcart e-Commerce: before 2.12.1 — fixed in 2.12.1
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.12.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15671 or the next vulnerability affects your stack