What’s Vulnerable › Vulnerabilities
CVE-2025-15674: Content Protector (Passster) < 4.3.7 - Contributor+ Protected Content Disclosure via Core REST API
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-09-29
- Weakness: CWE-863
Description
The Passster WordPress plugin before 4.3.7 does not restrict low-privilege users holding the edit_posts capability from reading globally password-protected content through the WordPress core REST API when global protection is enabled, allowing any Contributor or higher to read the content of protected pages and posts without knowing the password.
Affected products
- Passster: before 4.3.7 — fixed in 4.3.7
How to fix
Upgrade to a fixed version: Passster 4.3.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15674 or the next vulnerability affects your stack