What’s Vulnerable › Vulnerabilities
CVE-2025-15675: Charitable < 1.8.5.3 - Admin+ Stored XSS via Photo Field ALT Text
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-02 · updated 2026-09-29
- Weakness: CWE-79
Description
The Charitable WordPress plugin before 1.8.5.3 does not sanitise and escape one of its campaign image text fields before outputting it in an HTML attribute, allowing users with a high-privilege campaign-management role to perform Stored Cross-Site Scripting attacks that execute on the front-end campaign page.
Affected products
- Charitable: before 1.8.5.3 — fixed in 1.8.5.3
How to fix
Upgrade to a fixed version: Charitable 1.8.5.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15675 or the next vulnerability affects your stack