What’s Vulnerable › Vulnerabilities
CVE-2025-15677: GeoDirectory < 2.8.110 - Editor+ Stored XSS via Place Categories
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-05 · updated 2026-09-29
- Weakness: CWE-79
Description
The GeoDirectory WordPress plugin before 2.8.110 does not sanitise and escape a place-category setting before outputting it back in an admin page, allowing high-privilege users such as editors and above to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in a multisite setup).
Affected products
- paoltaia GeoDirectory – WP Business Directory Plugin and Classified Listings Directory: before 2.8.110 — fixed in 2.8.110
How to fix
Upgrade to a fixed version: paoltaia GeoDirectory – WP Business Directory Plugin and Classified Listings Directory 2.8.110. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15677 or the next vulnerability affects your stack