What’s Vulnerable › Vulnerabilities
CVE-2025-15678: Nexter Blocks < 5.0.2 - Author+ Stored XSS via SVG Upload
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-09-29
- Weakness: CWE-79
Description
The Nexter Blocks WordPress plugin before 5.0.2 does not sanitize uploaded SVG files and allows SVG uploads for any user able to upload files (Author by default), allowing them to upload a file containing malicious JavaScript that executes when the file is accessed, leading to Stored Cross-Site Scripting.
Affected products
- Nexter Blocks: before 5.0.2 — fixed in 5.0.2
How to fix
Upgrade to a fixed version: Nexter Blocks 5.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15678 or the next vulnerability affects your stack