What’s Vulnerable › Vulnerabilities

CVE-2025-15690: Content Mask 1.7.1 - 1.8.5.5 - Contributor+ Stored XSS via Post Scripts and Styles

Description

The Content Mask WordPress plugin before 1.8.5.6 does not properly sanitise and escape content submitted with a post before outputting it in the pages it generates, allowing users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks against any user viewing or previewing the affected page. The Content Mask WordPress plugin before 1.8.5.6's option to restrict its use by role does not prevent this.

Affected products

How to fix

Upgrade to a fixed version: Content Mask 1.8.5.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-15690 or the next vulnerability affects your stack