What’s Vulnerable › Vulnerabilities
CVE-2025-15693: JCH Optimize 4.2.1 - 5.0.0 - Admin+ Path Traversal
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-10-19
- Weakness: CWE-22
Description
The JCH Optimize WordPress plugin before 5.0.1 does not properly restrict a directory path provided to one of its administrative image-browsing features to within the site, allowing high-privilege users, administrators on single-site and sub-site administrators on multisite, to enumerate directories and file names outside the web root.
Affected products
- JCH Optimize: from 4.2.1 before 5.0.1 — fixed in 5.0.1
How to fix
Upgrade to a fixed version: JCH Optimize 5.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15693 or the next vulnerability affects your stack