What’s Vulnerable › Vulnerabilities
CVE-2025-15694: Joli Table Of Contents 2.0.0 - 2.8.0 - Admin+ Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-10-19
- Weakness: CWE-79
Description
The Joli Table Of Contents WordPress plugin before 2.8.1 does not sanitise and escape some of its settings before outputting them in an admin page, which could allow high-privilege users such as administrators to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed, for example in a multisite setup.
Affected products
- Joli Table Of Contents: from 2.0.0 before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: Joli Table Of Contents 2.8.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15694 or the next vulnerability affects your stack