What’s Vulnerable › Vulnerabilities
CVE-2025-15695: GTranslate < 3.0.10 - Admin+ Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-11 · updated 2026-10-14
- Weakness: CWE-79
Description
The Translate WordPress with GTranslate WordPress plugin before 3.0.10 does not validate one of its settings before the bundled front-end scripts build markup from it, allowing users with a role as high as administrator to store JavaScript that runs in the session of any visitor to the site.
Affected products
- Translate WordPress with GTranslate: before 3.0.10 — fixed in 3.0.10
How to fix
Upgrade to a fixed version: Translate WordPress with GTranslate 3.0.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-15695 or the next vulnerability affects your stack