What’s Vulnerable › Vulnerabilities
CVE-2025-1627: Qi Blocks < 1.4 - Contributor+ Stored XSS via ToC Block
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The Qi Blocks WordPress plugin before 1.4 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- qodeinteractive Qi Blocks: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: qodeinteractive Qi Blocks 1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1627 or the next vulnerability affects your stack