What’s Vulnerable › Vulnerabilities
CVE-2025-1639: Animation Addons for Elementor Pro <= 1.6 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Plugin Installation/Activation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-04 · updated 2026-06-17
- Weakness: CWE-862
Description
The Animation Addons for Elementor Pro plugin for WordPress is vulnerable to unauthorized arbitrary plugin installation due to a missing capability check on the install_elementor_plugin_handler() function in all versions up to, and including, 1.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install and activate arbitrary plugins which can be leveraged to further infect a victim when Elementor is not activated on a vulnerable site.
Affected products
- crowdyTheme Arolax: before 1.7 — fixed in 1.7
How to fix
Upgrade to a fixed version: crowdyTheme Arolax 1.7. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/arolax-creative-digital-agency-theme/53547630
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fb310bdb-fc74-47b2-9371-3d10abd287fb?source=cve
Get alerted when CVE-2025-1639 or the next vulnerability affects your stack