What’s Vulnerable › Vulnerabilities
CVE-2025-1647: XSS in Bootstrap title attribute for Tooltip and Popover
- Severity: medium (CVSS 5.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-15 · updated 2026-10-09
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Bootstrap allows Cross-Site Scripting (XSS).This issue affects Bootstrap: from 3.4.1 before 4.0.0.
Affected products
- Bootstrap: from 3.4.1 before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Bootstrap 4.0.0. Check the vendor advisory for mitigations.
References
- https://www.herodevs.com/vulnerability-directory/cve-2025-1647
- https://lists.debian.org/debian-lts-announce/2025/06/msg00001.html
- https://lists.debian.org/debian-lts-announce/2026/10/msg00023.html
Get alerted when CVE-2025-1647 or the next vulnerability affects your stack