What’s Vulnerable › Vulnerabilities
CVE-2025-1686
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-73
Description
Versions of the package io.pebbletemplates:pebble from 0 and before 4.1.0 are vulnerable to External Control of File Name or Path via the include tag. A high privileged attacker can access sensitive local files by crafting malicious notification templates that leverage this tag to include files like /etc/passwd or /proc/1/environ. Workaround This vulnerability can be mitigated by disabling the include macro in Pebble Templates: java new PebbleEngine.Builder() .registerExtensionCustomizer(new DisallowExtensionCustomizerBuilder() .disallowedTokenParserTags(List.of("include")) .build()) .build();
Affected products
- io.pebbletemplates:pebble: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: io.pebbletemplates:pebble 4.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/PebbleTemplates/pebble/commit/b3451c8f305a1a248fbcc2363fd307d0baaee329
- https://github.com/PebbleTemplates/pebble/issues/680
- https://github.com/PebbleTemplates/pebble/issues/688
- https://pebbletemplates.io/wiki/tag/include
- https://security.snyk.io/vuln/SNYK-JAVA-IOPEBBLETEMPLATES-8745594
- https://github.com/PebbleTemplates/pebble/pull/715
- https://security.snyk.io/vuln/SNYK-JAVA-IOPEBBLETEMPLATES-8745594
Get alerted when CVE-2025-1686 or the next vulnerability affects your stack