What’s Vulnerable › Vulnerabilities
CVE-2025-1691: MongoDB Shell may be susceptible to Control Character Injection via autocomplete
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-74
Description
The MongoDB Shell may be susceptible to control character injection where an attacker with control of the mongosh autocomplete feature, can use the autocompletion feature to input and run obfuscated malicious text. This requires user interaction in the form of the user using ‘tab’ to autocomplete text that is a prefix of the attacker’s prepared autocompletion. This issue affects mongosh versions prior to 2.3.9. The vulnerability is exploitable only when mongosh is connected to a cluster that is partially or fully controlled by an attacker.
Affected products
- MongoDB Inc mongosh: before 2.3.9 — fixed in 2.3.9
How to fix
Upgrade to a fixed version: MongoDB Inc mongosh 2.3.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1691 or the next vulnerability affects your stack