What’s Vulnerable › Vulnerabilities
CVE-2025-1695: NGINX Unit Java Vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-04 · updated 2026-06-17
- Weakness: CWE-835
Description
In NGINX Unit before version 1.34.2 with the Java Language Module in use, undisclosed requests can lead to an infinite loop and cause an increase in CPU resource utilization. This vulnerability allows a remote attacker to cause a degradation that can lead to a limited denial-of-service (DoS). There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Unit: from 1.29.1 before 1.34.2 — fixed in 1.34.2
How to fix
Upgrade to a fixed version: F5 NGINX Unit 1.34.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1695 or the next vulnerability affects your stack