What’s Vulnerable › Vulnerabilities
CVE-2025-1731
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-22 · updated 2026-06-17
- Weakness: CWE-732
Description
An incorrect permission assignment vulnerability in the PostgreSQL commands of the Zyxel USG FLEX H series uOS firmware versions from V1.20 through V1.31 could allow an authenticated local attacker with low privileges to gain access to the Linux shell and escalate their privileges by crafting malicious scripts or modifying system configurations with administrator-level access through a stolen token. Modifying the system configuration is only possible if the administrator has not logged out and the token remains valid.
Affected products
- Zyxel USG FLEX H series uOS firmware: from 1.20 before 1.32 — fixed in 1.32
How to fix
Upgrade to a fixed version: Zyxel USG FLEX H series uOS firmware 1.32. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-incorrect-permission-assignment-and-improper-privilege-management-vulnerabilities-in-usg-flex-h-series-firewalls-04-22-2025
- http://seclists.org/fulldisclosure/2025/Apr/27
Get alerted when CVE-2025-1731 or the next vulnerability affects your stack