What’s Vulnerable › Vulnerabilities
CVE-2025-1735: pgsql extension does not check for errors during escaping
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-13 · updated 2026-06-17
- Weakness: CWE-89
Description
In PHP versions:8.1.* before 8.1.33, 8.2.* before 8.2.29, 8.3.* before 8.3.23, 8.4.* pgsql and pdo_pgsql escaping functions do not check if the underlying quoting functions returned errors. This could cause crashes if Postgres server rejects the string as invalid.
Affected products
- PHP: from 8.1.0 before 8.1.33; from 8.2.0 before 8.2.29; from 8.3.0 before 8.3.23; from 8.4.0 before 8.4.10 — fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10
How to fix
Upgrade to a fixed version: PHP 8.1.33, 8.2.29, 8.3.23, 8.4.10. Check the vendor advisory for mitigations.
References
- https://github.com/php/php-src/security/advisories/GHSA-hrwm-9436-5mv3
- http://www.openwall.com/lists/oss-security/2025/07/11/4
- https://lists.debian.org/debian-lts-announce/2025/07/msg00017.html
Get alerted when CVE-2025-1735 or the next vulnerability affects your stack