What’s Vulnerable › Vulnerabilities
CVE-2025-1736: Stream HTTP wrapper header check might omit basic auth header
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-30 · updated 2026-06-17
- Weakness: CWE-20
Description
In PHP from 8.1.* before 8.1.32, from 8.2.* before 8.2.28, from 8.3.* before 8.3.19, from 8.4.* before 8.4.5, when user-supplied headers are sent, the insufficient validation of the end-of-line characters may prevent certain headers from being sent or lead to certain headers be misinterpreted.
Affected products
- NetApp ONTAP 9: 9
- PHP: from 8.1.0 before 8.1.32; from 8.2.0 before 8.2.28; from 8.3.0 before 8.3.19; from 8.4.0 before 8.4.5 — fixed in 8.1.32, 8.2.28, 8.3.19, 8.4.5
How to fix
Upgrade to a fixed version: PHP 8.1.32, 8.2.28, 8.3.19, 8.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/php/php-src/security/advisories/GHSA-hgf5-96fm-v528
- https://lists.debian.org/debian-lts-announce/2025/03/msg00014.html
- https://security.netapp.com/advisory/ntap-20250523-0006/
Get alerted when CVE-2025-1736 or the next vulnerability affects your stack