What’s Vulnerable › Vulnerabilities
CVE-2025-1746: Cross-Site Scripting vulnerability in OpenCart
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-Site Scripting vulnerability in OpenCart versions prior to 4.1.0. This vulnerability allows an attacker to execute JavaScript code in the victim's browser by sending the victim a malicious URL using the search in the /product/search endpoint. This vulnerability could be exploited to steal sensitive user data, such as session cookies, or to perform actions on behalf of the user.
Affected products
- OpenCart: before 4.1.0.0 — fixed in 4.1.0.0
How to fix
Upgrade to a fixed version: OpenCart 4.1.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1746 or the next vulnerability affects your stack