What’s Vulnerable › Vulnerabilities
CVE-2025-1755: MongoDB Compass may be susceptible to local privilege escalation in Windows
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-426
Description
MongoDB Compass may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privileges, when a crafted file is stored in C:\node_modules\. This issue affects MongoDB Compass prior to 1.42.1
Affected products
- MongoDB Compass: before 1.42.1 — fixed in 1.42.1
- RedHat Enterprise Linux For Arm 64: 9.0_aarch64
- RedHat Enterprise Linux For Ibm Z Systems: 9.0_s390x
- RedHat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions: 9.0_ppc64le
- RedHat Enterprise Linux Update Services For Sap Solutions: 9.0
How to fix
Upgrade to a fixed version: MongoDB Compass 1.42.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1755 or the next vulnerability affects your stack