What’s Vulnerable › Vulnerabilities
CVE-2025-1756: MongoDB Shell may be susceptible to local privilege escalation in Windows
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-426
Description
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules\. This issue affects mongosh prior to 2.3.0
Affected products
- MongoDB Inc mongosh: before 2.3.0 — fixed in 2.3.0
- RedHat Codeready Linux Builder Eus: 9.4
- RedHat Codeready Linux Builder For Arm64 Eus: 9.4_aarch64
- RedHat Codeready Linux Builder For Ibm Z Systems Eus: 9.4_s390x
- RedHat Codeready Linux Builder For Power Little Endian Eus: 9.4_ppc64le
- RedHat Enterprise Linux Eus: 9.4
- RedHat Enterprise Linux For Arm 64: 9.4_aarch64
- RedHat Enterprise Linux For Arm 64 Eus: 9.4_aarch64
- RedHat Enterprise Linux For Ibm Z Systems: 9.4_s390x
- RedHat Enterprise Linux For Ibm Z Systems Eus: 9.4_s390x
- RedHat Enterprise Linux For Power Little Endian Eus: 9.4_ppc64le
- RedHat Enterprise Linux Server Aus: 9.4
- RedHat Enterprise Linux Update Services For Sap Solutions: 9.4
How to fix
Upgrade to a fixed version: MongoDB Inc mongosh 2.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1756 or the next vulnerability affects your stack