What’s Vulnerable › Vulnerabilities
CVE-2025-1771: Traveler <= 3.1.8 - Unauthenticated Local File Inclusion via hotel_alone_load_more_post
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-15 · updated 2026-06-17
- Weakness: CWE-98
Description
The Traveler theme for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 3.1.8 via the 'hotel_alone_load_more_post' function 'style' parameter. This makes it possible for unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where php file type can be uploaded and included.
Affected products
- shinetheme Traveler: before 3.1.9 — fixed in 3.1.9
How to fix
Upgrade to a fixed version: shinetheme Traveler 3.1.9. Check the vendor advisory for mitigations.
References
- https://travelerwp.com/traveler-changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/da3e3d6c-7643-4f22-aa88-2c4ce80aed1f?source=cve
Get alerted when CVE-2025-1771 or the next vulnerability affects your stack